Problems with the Edit Mode
Incident Report for Jimdo
Resolved
A short time ago we deployed a fix for the missing menu issue and all users should have full functionality again.
Posted Jan 12, 2017 - 16:58 CET
Identified
We have identified an issue with our Edit Mode that causes the Menu to not appear. Our technicians are working on it currently and we hope to have this resolved as quickly as possible.
Posted Jan 12, 2017 - 16:34 CET