Partial Server Outage
Incident Report for Jimdo
Resolved
This incident has been resolved.
Posted Oct 12, 2020 - 12:29 CEST
Update
We are continuing to investigate this issue.
Posted Oct 12, 2020 - 12:28 CEST
Investigating
We are currently investigating this issue.
Posted Oct 12, 2020 - 12:07 CEST
This incident affected: Jimdo Creator (Website Delivery, Content Management System).