Log in error for some Jimdo Mail users
Incident Report for Jimdo
Resolved
The general issues has been solved, it may only occur in a few edge cases.
If you should be affected, please contact our support, we created a work around to handle this.
Posted almost 2 years ago. Jun 30, 2017 - 15:44 CEST
Identified
We have been informed by our Service Provider for Jimdo Mail that if users have special characters in their password (e.g. +,&,%,@, ,-,_) they will be unable to log in to Jimdo Mail. If you are affected by this issue then as a temporary measure you can use the password reset feature and create a new password. Characters A-Z, a-z and 0-9 are not affected.
Posted over 2 years ago. Feb 13, 2017 - 13:45 CET