Jimdo Website Builder: Email settings reset for some domains

Incident Report for Jimdo

Resolved

The error has been resolved. All missing records should be restored. If you need any assistance, please reach out to our support team
Posted Apr 26, 2025 - 08:27 CEST

Update

Our engineers have implemented a fix for the issue. It will take a couple of hours to roll out. In the meanwhile, manually restoring the settings will still work.
Posted Apr 25, 2025 - 14:49 CEST

Identified

We are currently investigating an issue where domain settings for a portion of our customers appear to have been reset. As a result, customers who use their Jimdo domain with external email providers may experience disruptions, such as being unable to send or receive emails through their domain-based email addresses.

If your domain is affected, manually restoring the email settings should resolve this presently while our engineers are working on a global solution.
Posted Apr 25, 2025 - 13:18 CEST
This incident affected: Jimdo Creator (Website Delivery, Image Delivery, Content Management System, User-Content Delivery, Nameserver, E-Mail Delivery System Central Europe, E-Mail Delivery System North America, E-Mail Delivery System Asia / Pacific) and Jimdo Website Builder (Website Delivery, Image Delivery, Content Management System, User Content Delivery, Nameserver).