Email access issue
Incident Report for Jimdo
Resolved
On 18 February 2023 starting at 11:55 CST, a portion of our hosted email customers may have experienced email connectivity issues. This issue has been resolved. The impacted mail services were recovered by our Support at 18:20 CST. We have determined this incident was caused by a scheduled process that failed to complete successfully, creating issues with accessing mailboxes. Any mail that would have been sent during this time, was queued and has since been delivered. We do not believe any mail sent during this time would be lost or missing from users mailboxes. A Root Cause Analysis session will be conducted and an Incident Report will be prepared and made available upon request later this week. If you have any questions, please contact a member of your support team. Thank you for your patience.
Posted Feb 19, 2023 - 04:06 CET
Update
Thank you for your continued patience. Engineers are progressing in our efforts to restore service and investigate the root cause. We will update the status page as additional information becomes available.
Posted Feb 19, 2023 - 01:18 CET
Update
Thank you for your patience. Service is actively being restored and we will continue to keep the status page updated.
Posted Feb 19, 2023 - 00:00 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 18, 2023 - 22:14 CET
Investigating
We are currently facing issues with webmail login / email access. Our email provider's engineers are actively investigating the issue. More details will be posted as they become available.
Posted Feb 18, 2023 - 20:49 CET
This incident affected: Jimdo Creator (E-Mail Delivery System Central Europe, E-Mail Delivery System North America, E-Mail Delivery System Asia / Pacific).