Jimdo Creator E-Mail Delivery Outage
Incident Report for Jimdo
Resolved
This incident has been resolved.
Posted Mar 30, 2021 - 08:33 CEST
Update
We are continuing to investigate this issue.
Posted Mar 30, 2021 - 08:33 CEST
Investigating
Errors in contact forms, shop orders and domain registrations.
Posted Mar 30, 2021 - 08:17 CEST
This incident affected: Jimdo Creator (E-Mail Delivery System Central Europe, E-Mail Delivery System North America, E-Mail Delivery System Asia / Pacific).