Rackspace
Incident Report for Jimdo
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 14:12 CET
Update
Our service partner has implemented a fix, and webmail.jimdo.com should be accessible again for all users. If you still run into errors, please try again after clearing the browser cache. Reach out to support, if any issues persist or you have further questions.

We'll continue to monitor the situation closely to make sure everything works as intended.
Posted Jan 25, 2023 - 11:32 CET
Monitoring
Our service partner has implemented a fix, and webmail.jimdo.com should be accessible again for all users. If you still run into errors, please try again after clearing the browser cache. Reach out to support, if any issues persist or you have further questions.

We'll continue to monitor the situation closely to make sure everything works as intended.
Posted Jan 25, 2023 - 11:31 CET
Update
We’re continuing to monitor the situation. Numerous users have reported they are again able to log in to Webmail. If the error still occurs on your end, please try the following:
- clear your browser cache and reload the page
- log in via https://webmail.emailsrvr.com/ (skip password recovery step, if prompted)
- connect to your mail account using any standard email client (e.g. Outlook, Windows Mail, Thunderbird)
Posted Jan 20, 2023 - 15:37 CET
Investigating
We are currently investigating this issue. If affected, try alternative login URL https://webmail.emailsrvr.com/ or connecting via email client.
Posted Jan 19, 2023 - 18:18 CET
This incident affected: Jimdo Creator (E-Mail Delivery System Central Europe).