Webmail access outage

Incident Report for Jimdo

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 08:08 CET

Update

Our email hoster has resolved the issue.
Posted Oct 30, 2025 - 08:08 CET

Identified

We're currently facing an issue with webmail access. Our provider is investigating the problem. Email delivery is unaffected, and you can still access your emails through clients like Outlook, Apple Mail, or others. We will provide updates as soon as possible.
Posted Oct 29, 2025 - 21:31 CET
This incident affected: Jimdo Creator (Webmail).