All services have been reported as operating normally again.
Posted Nov 18, 2025 - 20:19 CET
Update
A fix has been implemented and the incident should now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 15:47 CET
Monitoring
Our service provider has made changes that have allowed affected systems to recover. They are continuing working on restoring all services.
Posted Nov 18, 2025 - 14:58 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 14:20 CET
Investigating
We’re currently experiencing accessibility issues with Jimdo websites and internal systems due to ongoing problems with one of our infrastructure providers. This may affect the availability of Jimdo customers' websites and parts of our platform. We’re monitoring the situation closely and will update as soon as our infrastructure provider has resolved the situation.