jimdo.com home page not accessible
Incident Report for Jimdo
Resolved
This incident has been resolved.
Posted Nov 29, 2023 - 11:53 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2023 - 11:20 CET
Investigating
Our website jimdo.com can currently not be opened. User websites are not affected! To log in to your user dashboard, please use this direct link: https://account.e.jimdo.com/de/accounts/login/
Posted Nov 29, 2023 - 10:41 CET
This incident affected: Jimdo Creator (Website Delivery) and Jimdo Website Builder (Website Delivery).