CMS editor isn't accessible

Incident Report for Jimdo

Resolved

The incident has been resolved. All systems are operational. Thank you for your patience.
Posted Jun 19, 2026 - 14:28 CEST

Monitoring

A fix has been implemented, and the CMS Editor is accessible again. We're closely monitoring the situation.
Posted Jun 19, 2026 - 13:45 CEST

Identified

An error started occurring in our CMS Editor around 12:00 CET, causing a partial outage.

We have identified the issue and are applying a fix. Thank you for your patience.
Posted Jun 19, 2026 - 13:37 CEST
This incident affected: Jimdo Creator (Content Management System).