Jimdo Creator Outage
Incident Report for Jimdo
Resolved
This incident has been resolved.
Posted Mar 16, 2022 - 11:39 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2022 - 15:23 CET
Investigating
We’re having a technical problem in Jimdo Creator right now, and we’re working to fix it.
Posted Mar 14, 2022 - 11:53 CET
This incident affected: Jimdo Creator (Website Delivery).