Access to some Jimdo Sites is limited.
Incident Report for Jimdo
Resolved
All websites should now be fully accessible again.
Posted over 2 years ago. Jan 31, 2017 - 14:03 CET
Monitoring
Our Developer Team identified an issue with our Web Delivery System and implemented a fix at around 17:45 CET yesterday (30/01/17). All Jimdo Sites should now be displayed but we will continue to monitor the issue.
Posted over 2 years ago. Jan 31, 2017 - 08:39 CET
Investigating
We are currently investigating an issue causing some of our websites not to load. You may experience some connectivity problems. We will update you as soon as we have further information
Posted over 2 years ago. Jan 30, 2017 - 16:47 CET