Email - Degraded Performance
Incident Report for Jimdo
Resolved
The general issues was reported as solved by our provider, everything works fine again and as usual. If there should be any ongoing issues feel free to contact our support.
Posted about 2 years ago. Jul 04, 2017 - 09:29 CEST
Identified
One of our service providers reported the following issues:

- Latency when navigating the Webmail interface
- Slowness upon logging in to the Webmail interface
- Delayed email delivery
- Intermittent errors in the Webmail interface ie

This issues may affect users who use
- IMAP
- POP3
- Login via Webmail
Posted about 2 years ago. Jun 30, 2017 - 16:03 CEST