Degraded performance when accessing Jimdo mail email accounts
Incident Report for Jimdo
Resolved
Our service provider resolved the issue.
Posted about 2 years ago. Apr 28, 2017 - 08:38 CEST
Identified
Our service provider informed us that they're currently experiencing technical problems with the platform used for Jimdo mail, which can result in slow or unsuccessful logins. They're of course already working on a solution.
Posted about 2 years ago. Apr 27, 2017 - 17:56 CEST