partially outage for Jimdo Creator
Incident Report for Jimdo
Resolved
The issue solved - everything is back to normal.
Posted about 1 year ago. Apr 17, 2018 - 16:46 CEST
Investigating
Currently there are performance issues with our nameservers, which can result in a website not being delivered properly. The responsible team is informed and already working on a solution.
Posted about 1 year ago. Apr 17, 2018 - 16:11 CEST