Signup process for Creator websites not working

Incident Report for Jimdo

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 10:28 CEST

Monitoring

The issue has been mitigated. We're continuing to monitor the systems and optimize stability.
Posted Jun 13, 2025 - 10:20 CEST

Update

The incident is still under investigation. The error occurs intermittently. If you are affected, please try again after a few minutes.
Posted Jun 13, 2025 - 09:37 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 13, 2025 - 09:27 CEST

Update

We are continuing to investigate this issue.
Posted Jun 13, 2025 - 09:27 CEST

Investigating

We are investigating an issue blocking users from creating new websites in the Creator tool. The Jimdo Website Builder (Dolphin) is not affected.
Posted Jun 13, 2025 - 09:20 CEST
This incident affected: Jimdo Creator (Website Delivery, Image Delivery, Content Management System, User-Content Delivery, Nameserver, E-Mail Delivery System Central Europe, E-Mail Delivery System North America, E-Mail Delivery System Asia / Pacific) and Jimdo Website Builder (Website Delivery, Image Delivery, Content Management System, User Content Delivery, Nameserver).